Autor Thema: Frescobaldi Versionen - Tipps und Probleme  (Gelesen 24773 mal)

barrio

  • Gast
Kontext-Hilfe (Strg-F9)
« Antwort #15 am: Mittwoch, 11. Juli 2012, 11:00 »
Hat jemand von Euch die Kontexthilfe zum Laufen gekriegt? Was muss man als URL angeben, damit das für Befehle im Quelltext funktioniert?

SteuLoh

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #16 am: Freitag, 10. August 2012, 11:51 »
Hallo,

das würde mich auch interessieren.

martinusbaum

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #17 am: Freitag, 10. August 2012, 18:13 »
hallo,

für Windows folgendes:
a) online-Hilfe
in Einstellungen > Lilypond Dukumentation eintragen: http://lilypond.ort/doc/v2.14/    ... fertig

b) offline
es muss einen Ordner an einem beliebigen Ort geben ...\Dokumentation
in diesem z.B. die Hilfe in einer großen Seite http://www.lilypond.org/doc/v2.14/Documentation/usage-big-page
speichern.
Diese Datei umbenennen in index.html
dann in Fresco den Pfad auf den Ordner oberhalb von \Dokumentation eingeben: -ACHTUNG- : nicht Backslashes, sondern einfache slashes, z.B. so: c:/Programme/Frescobaldi

Fertig.
siehe auch hier: https://groups.google.com/forum/#!topic/frescobaldi/rV3e7ZlZbzE[1-25]

quadronado

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #18 am: Freitag, 10. August 2012, 19:15 »
Lilypond Dukumentation eintragen: http://lilypond.ort/doc/v2.14/    ... fertig
So funktioniert es bei mir leider nicht. Selbst wenn ich das "ort" durch "org" ersetze, führt der Link mit einer Fehlermeldung zur Lilypond-Startseite.

kilgore

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #19 am: Samstag, 11. August 2012, 12:12 »
achtung, Link ist falsch geschrieben!  lilpond.orT führt zu nichts :)

versuch' mit .org 

typomax

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #20 am: Sonntag, 25. November 2012, 22:23 »
Hallo,

ich bin absoluter Lilypond-Anfänger und habe mir deshalb zum leichteren Einstieg (neben dem Auswendiglernen der Syntax natürlich) gleich mal Frescobaldi geholt. "Gleich mal" soll heißen: Ich habe mir heute Abend nach mehreren Rumtestereien die jeweils aktuellen Versionen der beiden Programme heruntergeladen und auch jeweils zum Laufen bekommen. LP funktioniert super, Frescobaldi allerdings nicht so super, wie ihr an der angehängten Datei sehen könnt.

Jedes Mal, wenn ich auf "Noten stechen" klicke, erscheint im Lilypond-Protokoll etwas weiter unten folgender Treppenwitz:

"Starte lilypond-windows.exe 2.16.1 [laika_test.ly]...
Konnte lilypond-windows.exe nicht starten.
Bitte überprüfen Sie den Pfad und die Berechtigungen."


Was mache ich falsch? Funktionieren die beiden Versionen einfach nicht miteinander, obwohl es die jeweils aktuellen sind?
Ich nutze Lilypond und Frescobaldi auf einem Windows-XP-PC von 2008. Der Witz dabei: Auf meinem Laptop bekam ich genau die gleiche Meldung angezeigt. Als sei sie für mich getextet worden!

Ich bitte um eure Hilfe, wie ich die Lilypond-Vorschau im Frescobaldi zum Laufen bringe ... Danke!!  :)

Grüße
Basti

Be-3

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #21 am: Montag, 26. November 2012, 13:38 »
Hallo Basti,

willkommen im Forum!
Die Fehlermeldung ist nicht so irreführend, wie sie auf den ersten Blick erscheinen mag:
Berechtigunsprobleme unter Windows sind natürlich normalerweise nicht zu erwarten, aber den Pfad solltest Du tatsächlich überprüfen.
Ich habe es jedenfalls geschafft, durch einen falschen Pfad zur lilypond-windows.exe genau diese Fehlermeldung zu provozieren.
Vermutlich stimmt bei Dir also der Pfad zur Lilypond-Exe-Datei nicht:

Bearbeiten -> Einstellungen
Lilypond-Einstellungen


Hier kannst Du bei "Zu benutzende LilyPond-Version" die lilypond-windows.exe mit komplettem Pfad eintragen. Wenn sich da ein Fehler eingeschlichen hat, kommt es zu der Meldung, die Du beschrieben hast.

Die Vorschau sollte dann auch funktionieren. Falls nicht, überprüfe, ob bei
Werkzeugansicht -> Notenansicht
ein Häkchen gesetzt ist.

Viele Grüße
Torsten

typomax

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #22 am: Montag, 26. November 2012, 13:59 »
Hallo Torsten,

danke für die flotte Info!

Deine Schritte habe ich befolgt - nur geht es immer noch nicht  :'( Ich finde in C:/Programme/Lilypond keine lilypond.exe?? Kann das sein?? Schlussendlich kann ich diese ja dann auch nicht angeben?

Im Anhang nochmal ein Bild.

Danke für Deine Hilfe!

Beste Grüße Basti


PS: Habe die Datei nun gefunden, kann sie aber nicht auswählen ... was nun? --- siehe Screenshot!
« Letzte Änderung: Montag, 26. November 2012, 14:08 von typomax »

Be-3

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #23 am: Montag, 26. November 2012, 14:50 »
Hallo Basti,

daß du unten bei "LilyPond-Include-Verzeichnis" keine EXE-Datei auswählen kannst, ist schon so beabsichtigt: gemeint ist nämlich das Verzeichnis bzw. die Verzeichnisse, in denen mit "\include" einzubindende Dateien gesucht werden.
Ich meinte, Du müßtest oben bei "Zu benutzende LilyPond-Versionen" den vollen Pfad incl. lilypond-windows.exe-Datei eingeben, also in Deinem Fall wohl

C:\Programme\LilyPond\usr\bin\lilypond-windows.exe

Allerdings scheint Dein Eintrag (ohne Pfad davor) ja auch zu funktionieren, denn sonst würde statt der Seerose davor ein Einbahnstraßen-Icon erscheinen. Und die Version (2.16.1) wird ja auch richtig erkannt und angezeigt. Daran sollte es eigentlich nicht liegen.

Läßt sich Lilypond "manuell" aufrufen; also per Kommandozeile?
Wie sind die Umgebungsvariablen eingestellt? Um das herauszufinden, kannst Du in Kommandozeile

echo %path%

eintippen.

Viele Grüße
Torsten

typomax

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #24 am: Montag, 26. November 2012, 14:53 »
Hi Torsten,

es hat geklappt!!! Super super super - danke Dir!
Habe den Pfad einfach oben eingegeben, und siehe da - es hat funktioniert!  :)

DANKE! ... dann werd' ich jetzt mal loslegen ;)

Beste Grüße
Basti

barrio

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #25 am: Sonntag, 13. Januar 2013, 22:22 »
Hi zusammen,

hat irgendwer MIDI-Input über RUMOR unter 2.0.x hingekriegt? Ich hab jetzt mal 2.0 runtergeworfen, unter 1.2 funktioniert es tadellos. Betreibt jemand evtl. beide Versionen parallel, eine über Paketquellen & eine selbstcompiliert?

TNX barrio

kilgore

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #26 am: Freitag, 25. Januar 2013, 16:31 »
Liebe Lilys!

Nach einige Rechner Probleme habe ich nun alles wieder installiert....jetzt bin ich beim bekannten Problem: Ich schaffe es nicht mehrere Lilypond-Versionen unter Frescobaldi zum laufen zu bringen.  Ich habe viele Dateien noch in 2.14.2 und möchte das auch noch drauf haben, die neuen Sachen sind schon in 2.16.2. 

Ich nutze Lubuntu 12.10 und die aktuellste Frescobaldi Version.

2.14.2 habe ich von den Repositories installiert, und es erscheint auch in Frescobaldi.  Wenn ich aber 2.16.2 manuell installiere, verschwindet in Frescobaldi 2.14.2 und es steht nur 2.16.2. 

Ich bin jetzt mehrfach hin und her gegangen...ich weiß nicht mehr wie ich das vorher geschafft habe!

Tipps?

Danke!

Gruß
kil

trulli

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #27 am: Samstag, 26. Januar 2013, 19:30 »
Ich nutze Lubuntu 12.10 und die aktuellste Frescobaldi Version.

Hallo Kil,

welche Version ist das denn? Die neuste Version kannst du über die Software-Funktion ja nicht installieren. Notfalls kannst du eine ältere Version (1.2.0) installieren - dort kannst du, wie üblich, über "Frescobaldi einrichten/LilyPond/LilyPondVersionen" alle nötigen Lily Versionen installieren und nutzen.

Grüße

kilgore

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #28 am: Sonntag, 27. Januar 2013, 11:14 »
Hi Trulli,

Das ist die Stable 2.0.8 von Frescobaldi.

Ich habe versucht die alte Version von Lilypond dazuzufügen, aber es nennt es trotzdem 2.16.2 und kann 2.14.2 Dateien nicht als solche kompilieren...

trulli

  • Gast
Re: Frescobaldi Versionen - Tipps und Probleme
« Antwort #29 am: Sonntag, 27. Januar 2013, 12:18 »
Das Problem hatten wir hier schon mal, dass 2er Versionen keine Auswahl für die Installation verschiedener LilyPond-Versionen lassen.

Installiere lieber 1.2.x, da geht es in jedem Falle.

Gruß