Autor Thema: Probleme mit Windows Vista  (Gelesen 7866 mal)

admin

  • Administrator
  • *****
  • Beiträge: 0
Probleme mit Windows Vista
« am: Montag, 28. Mai 2007, 11:18 »
Lilypond reagiert unter Windows Vista sehr langsam. So dauert es ca. 60 Sekunden bis aus einer Lilyponddatei eine PDF geworden ist. Leider habe ich noch nirgends eine Lösung dazu gefunden. Weiß jemand, wie man Lilypond unter Vista schneller macht?

bongtschik

  • Gast
Re: Probleme mit Windows Vista
« Antwort #1 am: Sonntag, 2. September 2007, 14:42 »
Hallo,

das Problem hatte ich auch. Ein Bekannter von mir (Lilypond-Freak)
meinte, das läge an Vista.

Ich habe mir nun zusätzlich zu Vista parallel Linux installiert,
und da läuft Lilypond wie die Eisenbahn!

Gruß,

bongtschik

admin

  • Administrator
  • *****
  • Beiträge: 0
Re: Probleme mit Windows Vista
« Antwort #2 am: Sonntag, 2. September 2007, 19:27 »
Ja, das es an Vista liegt, war mir klar. Ich wollte wissen, ob es dazu eine Lösung gibt - vielleicht noch eine andere als gleich ein anderes Betriebssystem zu installieren :) Aber trotzdem danke, dass du dich erkundigt hast.

goldeagle

  • Gast
Re: Probleme mit Windows Vista
« Antwort #3 am: Donnerstag, 6. September 2007, 21:43 »
Moin.

Das Problem hatte ich auch die ganze Zeit.

Seit längerer Zeit benutze ich für manche Sachen die Konsole Cygwin (WIKI: Cygwin [ˈsɪɡwɪn] ist eine Emulation der Linux-API unter verschiedenen Versionen von Microsoft Windows, auf deren Basis eine Vielzahl von Programmen aus der Unix-Welt unter Microsoft Windows bereitgestellt werden kann.)
Vor kurzem kam mir die Idee, damit Lilypond auszuprobieren — und tatsächlich, so funktioniert es (komischerwiese) einwandfrei.
Dort findet man beim Server http://linux.rz.ruhr-uni-bochum.de sogar die aktuellste 29er Version (Server wählen => Interpreters => Lilypond).

Nun bin ich seit paar Tagen am lilyponden :)

Hoffe, konnte weiterhelfen.

Gruß Erik

PS: Cygwin ist hier zu finden: http://www.cygwin.com/
PS2: Hab auch nen guten Lilypond-Editor gefunden: http://jedit.org . Man muss aber die Entwicklerversion downloaden, denn sonst funktionert das Lilypond-Plugin (entweder im Programm laden oder hier: http://lilypondtool.organum.hu/87.0.html ) nicht !

dgippner

  • Gast
Re: Probleme mit Windows Vista
« Antwort #4 am: Donnerstag, 4. Oktober 2007, 14:26 »
Wenn man allerdings lilypond-book mit OpusTeX verwendet, ist das ganz schön aufwändig. Ich hätte das komplette LaTeX-System, das ich verwende, auf cygwin portieren müssen. Also habe ich mal an die lilypond-users-Liste geschrieben, ob schon jemand weiß woran es liegt. Mein Verdacht ist ja die Speicherbegrenzung für Konsolenprogramme, das ist allerdings ziemlich ins Blaue hinein gesprochen.

dgippner

  • Gast
Re: Probleme mit Windows Vista
« Antwort #5 am: Donnerstag, 25. Oktober 2007, 01:06 »
Das Problem hat sich als ein Problem mit der mitgelieferten fontconfig-Version herausgestellt.

benutzt man die Version von hier:
http://ftp.gnome.org/pub/gnome/binaries/win32/dependencies/fontconfig-2.4.2-tml-20071015.zip

geht alles gewohnt fix.

Liebe Grüße
David

admin

  • Administrator
  • *****
  • Beiträge: 0
Re: Probleme mit Windows Vista
« Antwort #6 am: Donnerstag, 25. Oktober 2007, 18:45 »
Leider funktioniert es nicht ganz so einfach. Problemlösung gibt's hier: http://thomas.lippert.it/v4/2007/lilypond-luft-nun-unter-vista/

dgippner

  • Gast
Re: Probleme mit Windows Vista
« Antwort #7 am: Montag, 29. Oktober 2007, 17:43 »
Diese Dateien hatte ich wohl dank cygwin schon. Danke für den Hinweis!