Autor Thema: kann aus Frescobaladi nicht midi abspielen  (Gelesen 6402 mal)

stefanhuglfing

  • Gast
kann aus Frescobaladi nicht midi abspielen
« am: Sonntag, 28. September 2014, 09:49 »
seit ich linux-mint (neueste Version) verwende, kann ich mit frescobaldi meine geschriebenen Noten nicht mehr als midi-Datei abspielen.
Vorher (mit ubuntu 12.04) war das problemlos möglich.

Ich habe jetzt auch den VLC Media Player installiert und kann damit midi-Dateien anhören. Nur aus Frescobaldi heraus geht es nicht.
Auch egal, was ich in Frescobaldi bei Bearbeiten - Einstellungen - Midi-Einstellungen einstelle.
« Letzte Änderung: Samstag, 8. November 2014, 20:04 von stefanhuglfing »

iugin

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #1 am: Sonntag, 28. September 2014, 14:46 »
Hallo

vielleicht eine blöde Frage: hast du timidity installiert?
Oder vielleicht hilft dir das: http://musix-wiki.org/index.php?title=Frescobaldi#MIDI-Konfiguration

Grüsse

Eugenio
« Letzte Änderung: Sonntag, 28. September 2014, 14:49 von iugin »

stefanhuglfing

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #2 am: Samstag, 8. November 2014, 20:03 »
nein, das war keine blöde Frage.
Ich dachte, so was wäre bei linux-mint sowieso dabei.

Jetzt habe ich timidity installiert.
(libportmidi0 , wie hier http://musix-wiki.org/index.php?title=Frescobaldi#MIDI-Konfiguration beschrieben, war schon installiert.)

Es geht leider immer noch nichts.

Hat jemand noch einen Tipp?

trulli

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #3 am: Sonntag, 9. November 2014, 15:49 »
Hi,

in den Einstellungen (-> MIDI Einstellungen -> MIDI Ports) sollten nach der Installation von TiMidity auch seine Ports auftauchen, z.B. TiMidity port 0.

Hast du das mal kontrolliert?

Grüße von trulli

stefanhuglfing

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #4 am: Sonntag, 9. November 2014, 20:23 »
leider tauchen die Timidity-Ports nicht auf.

Es steht nur: "Midi Through Port-0" im Aufklappmenü

sowohl bei Player-Ausgabe, als auch bei Input port.

Ich habe es auch schon mit QjackCtl probiert, aber da steht auch nur  Midi Through Port-0.

Was kann ich tun?

trulli

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #5 am: Sonntag, 9. November 2014, 23:10 »
Vermutlich ist Timidity in einem Ordner installiert, in dem Frescobaldi nicht sucht.

Prüf erstmal ob TiMidity überhaupt richtig installiert wurde, also starte es grafisch oder über die Konsole.
Wenn das geht: suche den Installationsordner, er sollte in \usr liegen (z.B. \usr\bin oder \usr\share). Wenn er dort nicht liegt, dann installiere TiMidity dort.

Wenn alles nicht hilft, dann geht als letzte Methode noch: ERST Timidity nochmal installieren, danach nochmal Frescobaldi.

Gruß

iugin

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #6 am: Montag, 10. November 2014, 22:53 »
Ich weiss nicht ob es hilft.
Im Attachement ein Screenshot von meinen Einstellungen in Frescobaldi.
Wo timidity ist findest du mit
Zitat
which timidity
bei mir ist es in
Zitat
/usr/bin

Liebe Grüsse

Eugenio

stefanhuglfing

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #7 am: Freitag, 14. November 2014, 21:42 »
wenn ich timidity über die Konsole starte, kommt:

TiMidity++ version 2.13.2 -- MIDI to WAVE converter and player
Copyright (C) 1999-2004 Masanao Izumo <iz@onicos.co.jp>
Copyright (C) 1995 Tuukka Toivonen <tt@cgs.fi>

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA


TiMidity++ version 2.13.2 -- MIDI to WAVE converter and player
Copyright (C) 1999-2004 Masanao Izumo <iz@onicos.co.jp>
Copyright (C) 1995 Tuukka Toivonen <tt@cgs.fi>

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

der Installationsordner liegt in \usr\bin

meine Einstellungen sind genau so wie im screenshot von Eugenio.

Ich habe timidity und frescobaldi entfernt und noch mal erst timidita, dann frescobaldi installiert

Aber es geht trotzdem nichts.

fugenkomponist

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #8 am: Sonntag, 29. März 2015, 17:42 »
Hast du inzwischen eine Lösung gefunden? Ich benutze Frescobaldi 2.17, Timidity 2.13.2, vlc 2.1.6 (ich hatte mal ausprobiert, ob ich die MIDIs einfach durch cvlc abspielen lassen kann; außerhalb von Frescobaldi geht das auch).

Isabeklll

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #9 am: Dienstag, 28. April 2015, 09:51 »
Ohne Timidity wird es wohl nicht gehen..

fugenkomponist

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #10 am: Dienstag, 28. April 2015, 19:21 »
Vermutlich nicht, aber mit Timidity auch nicht, das ist im Moment unser Problem ;)

erich

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #11 am: Donnerstag, 30. April 2015, 16:34 »
Vielleicht mal Timidity in einem Befehlsfenster oder einer Konsole mit timidity -Os -iAD starten und dann einen port in Frescobalde aussuchen.
Erich

fugenkomponist

  • Gast
Re: kann aus Frescobaladi nicht midi abspielen
« Antwort #12 am: Montag, 19. Oktober 2015, 21:24 »
Huch, wie ist es möglich, dass ich diese absolut hilfreiche Antwort so lange übersehen habe? Vielen Dank! Ich muss jetzt bloß noch rauskriegen, wie ich timidity dazu bringe, so schön zu klingen wie vlc. Scheint u. a. andere Soundfonts zu verwenden …